[SOLVED] Team members can't push to repo despite having write access


I am hosting a repo over ssh, with the repo owned by an organization I created. The org has 1 admin and 1 team with 3 members. The team is granted write access, and gitea displays this description when viewing the team details: “This team grants Write access: members can read from and push to the team’s repositories”

The admin account is able to read and write from the repo with no issues. However, other users can only read (clone/pull) and are unable to push. The push fails with this message:

Gitea: You do not have sufficient authorization for this action User testacct does not have level write access to repository testorg/test.git fatal: Could not read from remote repository.

This was on an attempt to push to master, which I would like to allow. The ssh keys are added and valid. No branches (including master) are flagged as protected. I tried enabling and disabling pull requests to see if that was overriding default permissions for some reason, to no effect.

(edit: I also tried manually adding a member as a collaborator, which was denied because they are already in the org)

I would like to allow non-admins to push to this repo if they are ‘approved’ members of the relevant team(s). Since team access controls do not appear to do anything, what is the correct way to do this?

Thanks for any help.

gitea 1.3.2 w/postgres, running on ubuntu 16.0.4

[EDIT: ok I am dumb. I didn’t realize the repo had to be manually added to the team (despite the team creating it!). I did this and it looks to be working correctly now.]

Have you added the repository to the team’s repository list? And you also should check team’s units permissions to make sure you have checked code.