[solved] Git repository updated on disk but commits are not shown in the web interface


I am running gitea 1.3.2 on Linux with a couple of repositories. For some of them, commits pushed are accepted without error and the files on the server contains the new commits but the web interface does not show them.

For a newly created repository, the web page still show the “Quick Guide” after the push of commits.

In the MySQL database, in the table repository the entry for the newly created repository is still is_bare = 1 and size = 0 after the push.

Which mechanism is responsible to parsing the commits in a repository and updating the database ? How can I debug this ? I have LEVEL = Debug for the [log] section but did not find obvious issue :-/


There have been similar issues in the past; check out this one, for instance.

Thank you. The solution described here https://github.com/go-gitea/gitea/issues/2898#issuecomment-355493660 completely fixed my problem.

Awesome! Glad it worked :smiley: