Mirror of an empty repository


First I created an empty repository without any initialization. In a second step I created a mirror repository from repository in the first step with automatic synchronization.

Now I pushed some data to the main repository from step one but the mirrors never show some updates in Web-GUI but refs and objects in filesystem are up to date.

So my question. What can I do get Gitea also show new and updated objects in the mirror repository?

I hope someone can help me get this environment working.

Ok, I found out that Gitea does not update the entries in the SQLite database when migrating (mirroring) an uninitialized repository and then initializing the remote repository and synchronize this repository from mirror. In the table main.repository the “default_branch” must be set to “master” and the field “is_empty” to “0”. All files will then be displayed in the GUI of the mirror. I don’t know if this should be treated as a bug.

Hello everyone, because nobody has given an answer/comment on this topic so far, I wanted to actively ask again if the behaviour of Gitea is faulty here when a mirror is created from an uninitialized repository (description above).

Hello Andreas. I’m not able to answer to your question. However, as I’ve trouble trying to mirror a repository on a gitea server, may I ask you to detail the way you made the mirroring and the synchronization ? Here are my questions (feel free to not answer them if you find them boring, sorry for that):

  • Did you made any script ? Or did you only use the standard web interface ?
  • Did you created the initial empty repository on your gitea space under a “group” or “organisation”, directly in your space without any “group” ?
  • Did you generated the mirror using “New Migration” button on the top right of the gitea web interface ?

Hello antc, on remote I created an empty/uninitialized repository.

The mirror of this remote repository was created using the web interface.

Yes, the this repository on remote and mirror are created under a “organization”.

Yes, I generated the mirror using “New Migration” and “This repository will be a mirror”.

Thanks a lot Andreas. Hope you will have answer to your questions.
From my side, I tried to reproduce my problems on “Try Gitea” Official Instance . And on that “Try Gitea” Official Instance I do not have problem (I reproduced the processes , and it does not return any error). Then, I’m suspecting an admin config or something equivalent on the gitea instance I’m using. Have you tried to reproduce your problem on “Try Gitea” Official Instance ? It may help to know if it is a gitea general problem or a specific problem related to your gitea instance and its usage. It is a poor help, I’m afraid. But we never know …

Hi. try.gitea.com is always updated to the latest master (i.e. edge version), which is at pre-1.11. I think your problem was solved after releasing 1.10. In a couple of days 1.11rc1 will be released, and probably the next patch release for 1.10 (1.10.3 I believe?) as well. Look forward to any of those.

Hello guillep2k, is this an answer to my or antc question?
I also recreated the scenario on try.gitea.com, the result was the same. In the meantime I have also created an issue (https://github.com/go-gitea/gitea/issues/9630). However, there was no reaction to this so far.

I am also facing the same exact issue. !!!