Gitea plugin for Intellij IDE platform is out

Hi everyone.

I wrote a Gitea plugin for Intellij IDE platform.
In a couple of days it will appear at Jetbrains plugin site, and so far you can download it at Releases · e1fueg0/intellij-gitea-plugin · GitHub.


It also appeared at the plugin site.

Hi, I tried it, but can’t pass the [Test Connection] Button, I have gitea 1.4.2 installed…

And what is the error message?

I was outside yesterday and it wasn’t authenticating, but now at home it worked. My current problem is the project popup is empty, is there a config in the gitea that I have to turn on to enable REPOS_SEARCH endpoint?

I added a public repo, that one show up, is there a way to connect to the private repo on gitea?

So you used a private repo? ok, I’ll look at this.

I fixed the issue.
Now there is a project filter in the configure server window where you can select ‘owned by me’ and private projects will be listed.

You may try to install the new version manually or wait while they approve it in the plugin repo.

@elfuego an you plase update the readme or wiki with general usages guide? sounds intersting but can’t figure out how to use it.

Read this:

@elfuego I just downloaded your plugin but I don’t see a tab anywhere for gitea. It might not be compatible with the latest PHPStorm/IntelliJ etc.

It may not be compatible, if you’re using a quite old version, older than of 2017.

Try Not work · Issue #12 · e1fueg0/intellij-gitea-plugin · GitHub