Unable to use GPG

Hi, I used to enable sign commits and it used to work fine until lately I noticed it does not

I tried to double check data in app.ini and what in .gitconfig but no luck when I add default nothing gets signed and when I add key ID I get 2 errors:

`		Unable to commit-tree in temporary repo: esmail/test Error: exit status 1Stdout: Stderr: error: gpg failed to sign the data`


Unable to get default signing key: failed to parse gpg key openpgp: invalid argument: no armored data found

My app.ini (gpg part):

DEFAULT_TRUST_MODEL = collaboratorcommitter
#SIGNING_KEY         = default
SIGNING_KEY         = 55B46434BB81637F
SIGNING_NAME        = gitea
SIGNING_EMAIL       = git@esmailelbob.xyz
INITIAL_COMMIT      = always
CRUD_ACTIONS        = always
WIKI                = always
MERGES              = always

My .gitconfig:

        email = git@esmailelbob.xyz
        name = gitea
        signingkey = 55B46434BB81637F
        gpgsign = true
        program = gpg
        quotepath = false
        commitGraph = true
        writeCommitGraph = true
        advertisePushOptions = true
        procReceiveRefs = refs/for

PS: yes I added my own public key inside my account and verified it, made sure my key and gitea’s key did not expire

and I logged into gitea docker as git and tried to run gpg and it ran fine