[SOLVED] Redis support in gitea from downloads.gitea.io?

Hi, I just downloaded gitea-1.3-rc1 from downloads.gitea.io and tried to use it with redis according to instructions but got an error.

There is a blurb in that page stating that gitea should be rebuilt with redis support. Is it possible to enable this by default on the available downloads?

Please try with rc2, I think caching was broken in RC1 and should be fixed in latest version

Not sure if that is related or not, but the configuration

PROVIDER        = redis
PROVIDER_CONFIG = network=tcp,addr=:6379,db=0,pool_size=100,idle_timeout=180

that used to work in 1.2, causes an error in 1.3:

panic: session/redis: unsupported option '/srv/gitea/network'
1 Like

@thmo, I’m seeing the same problem on my 1.3.0 installation.

It seems like it’s not validating the value correctly, as it seems to be parsing it as the path of the folder that gitea is located.

Hope this gets fixed soon :blush:

Ok, I think there are two issue here:

  • the released binary is built without support for redis

  • in case of missing redis support, the gitea should error out already on PROVIDER = redis, and not silently fall back to PROVIDER = file, and subsequently fail on a “wrong” PROVIDER_CONFIG.

The latter sounds like a bug to me.

This has been fixed on release/v1.3 branch and will be released with v1.3.1