[solved] Raspian cannot execute binary file: Exec format error

First of all I’m new to gitea and still fresh to raspian but when trying to install gita via via the guide I get “cannot execute binary file: Exec format error” when trying to run gitea.

I wasn’t sure I installed the correct version so I’ve since tried a number arm processor builds (all of them from memory) and I still get the same issue.

I’m trying to run it on Raspian on a Raspberry Pi 4. I assume I should be using “gitea-1.13-linux-arm64” or “gitea-1.13-linux-arm-6”

Update… Like I said I’m fairy new such things.

using “./gitea” rather than just typing gitea worked. I’ll need to go back and look at the service as I’m sure I have an issue there as well. I’ll update anything else I find for any other green peeps like me.


so running that helped but now I can’t connect back to website and I’m not sure the service is running correctly. Trying to reconnect back the web UI only returns site can’t be reached.

I’m going to start with a fresh install and try again but if someone could confirm that is the right binary for a p4 that would be great!!!

NEVER MIND I Figured it out. I’m using the arm 6 version. Thanks all the same.