Raspberry Pi from binary

I’m trying to come up with the simplest thing that works to run a private Git server at home. I looked at GoGS, but Gitea is clearly the future. I’ve tried a number of different approaches to get this to work, and I think the “from binary” route is clearly the simplest, which is exactly what I’m going for. My trouble is that I just can’t get cloning to work over SSH, and I’m afraid I’m just simply overlooking something here.

After messing around with configurations and resetting multiple times, I end up with the message:

fatal: Could not read from remote repository.

Please make sure you have the correct access rights
and the repository exists.

This is mentioned in the troubleshooting guide, and I’ve done my best to work through that, but I ran gitea as the “pi” user, which I can normally SSH in as. In fact, I was SSHd in when I did it, so I know that my authorized_keys setup works. I have disabled password logins since I’m exposing this one through the firewall. Http clones work just fine apart from the constant nags to log in.

Anyway, I see several comments by others here and on discord that say they’ve been running it just fine. I’m wondering what I’m missing. My last attempt was earlier this evening on 1.3.3, since that seems to be the most recent “stable” release that I can see. If someone has this working with SSH cloning, I’d love to see their app.ini file to compare with what I have so I can see where I’m going wrong.


It seems it’s file permission issue. maybe you can try chown -R pi:pi <gitea_home> to change the permissions of the files.

The repository itself is on an external drive which is formatted with NTFS, so essentially there are no permissions. Everything appears to be 777 all the way down.

Does ssh pi@address show a message of this kind? Or does it allow you to log in? (So that we can understand if the ssh connection is actually tunneled to gitea)

$ ssh git@zxq.co
PTY allocation request failed on channel 0
Hi there, You've successfully authenticated, but Gitea does not provide shell access.
If this is unexpected, please log in with password and setup Gitea under another user.
Connection to zxq.co closed.