[SOLVED] Git clone via ssh asking for gitea user

When I try to clone a git repository created with gitea, I get asked for the password of the gitea user.
The public key I added to my Gitea account gets not used.
It seems to be the same or very similar issue discussed here: [SOLVED] Using regular Git ssh not working
Except that I’m used the latest Arch Linux.
It is a clean install of Gitea from the package manager with the default ssh settings in app.ini except for the SSH_DOMAIN which is set to the actual domain. (I am not using the build-in SSH server)
The user name for Gitea is gitea.

git clone gitea@$URL:ralf/GiteaSetup.git
is asking me for the password of gitea.

You need to add the gitea user to the AllowUsers in /etc/ssh/sshd_config :man_facepalming:

@Moderators: It may be a good idea to link this Post to the one I linked, so that people finding that post get inspired to check their ssh config :grin:

What is the point of having SSH keys in the UI then??

Please open an new topic.