Clone by SSH asks for password (FreeBSD)

When I try to clone a privat repository via ssh I get asked for a password.

$ git clone git@sub.domain.tld:USER/REPO
Cloning into 'REPO'...
git@sub.domain.tld's password:
  • My public key is added to the user account who owns the privat repo
  • My Gitea instance runs on a FreeBSD jail
  • The service was enabled by root with ‘service gitea enable’
  • ‘top’ shows that the gitea process is owned by git
  • $HOME of git contains an empty ‘.ssh’ directory
  • $HOME of git and it’s content is owned by git
  • I tried the same with a privat repo on GitHub with the same ssh key and it worked

I tried the solution from this thread
(Adding gitea to AllowUsers in /etc/ssh/sshd_config, which probably should be handled by the FreeBSD-port or at least be noted somwhere, if that really is a required setting)
After that .ssh/authorized_keys showed up and also contains my public key. But it still asks for a password.

Did I miss anything in my setup?
Thanks for any help in advance