Issue getting ssl forwarding to work with docker install

I followed the instructions here: to move my existing gitea instance into docker (I was moving servers and wanted to move most of my self hosted applications into docker).

Everything’s working great, except for forwarding SSH calls into the container. I get the following error:

bash: /home/git/gitea/gitea: No such file or directory

I tried running ssh on a non-standard port and exposing it directly from the container, and I get the same error, so I don’t think this is necessarily related to ssh forwarding.

I’ve tried creating that folder or file on the host and making sure the user running the container has access, but I still get the same error.

it looks like when I copied my gitea repositories folder from my older server, they came with some pre-recieve hooks in the repo folders that reflect old file paths.

However after removing the hooks folder completely (with backup), I still get the same error.

Also ran the Resynchronize pre-receive, update and post-receive hooks of all repositories. job from the Site Administration page and it didn’t change anything.

This is working now. I’m guessing something in one of the 24h maintenance operations fixed the hooks in the repositories over night.