SSH pass through container on Fedora 30


I’ve tried to set up an ssh connection towards a Gitea docker container so that I can perform git clone through ssh. There are some issues and questions that I’ve met along the way. The instruction that I followed is this:

  1. I sort of guessed that the file within /app/gitea/gitea is for preventing strict key check. But within Fedora 30. /app doesn’t exist in the first place. I’d highly doubt how it can work properly. Thus, if I’d like to stop the strict key check, what’s the correct path that I make the executable file?
  2. After I complete the instruction, copied the generated key pairs into the mounted volume. The ssh session returned to me with permission denied (public key)
  3. I then copied the key file from the server to the remote computer. The ssh session was successful, but git clone command still failed me. I wonder if I’ve typed in the wrong git clone command?
  4. A couple of things that I’ve done other than the instruction. I’ve set the SELINUX to be permissive, I’ve opened up the 2222 port with firewall-cmd as tcp port. I’ve set the port forwarding from 2222 on host server towards 22 on container. I’ve changed app.ini so that built-in ssh server is used.

Please help.

After some lookup and further research, I’m very much suspecting that the server user ‘git’ doesn’t have a proper access permission towards the repository within the container (Note that the gitea server is created under uid=git, but the database is not?)

Any other possible causes? Please help.

Problem fixed It’s the path that needs to be changed.
When using ssh, instead of git clone ssh://git@, you have to type git clone ssh://git@