Cannot load gitea instance website

I am writing here because I am not sure that this might be a bug. Since today my local gitea instance does not working anymore properly. But I have to get into more detail on this, as some parts are still working and that is what confuses me.

Setup: Windows Server with Gitea and MSSQL-backend running. Nginx providing Proxy-Support. No SSL involved as it is company internal.

Since today the external clients (my computer) cannot access the gitea instance webseite anymore. Well, the HTML is still loaded, but none of the CSS or JS-files. They just timeout after some time.

When I enter the JS-path directly into the browser it does not work either. Same with the CSS file. But still all the json-files and the images work when I enter them directly into the browser.

The CSS and JS-files also work, when I try to access them with curl.

The proxy seems not to be the problem, as Redmine and other tools still work. And if the proxy was the problem the curl-access would not work either, I figured. Also none of the problems above resolve either when I access gitea directly via port 3000 thus ignoring the proxy.

Everything works btw when I log onto the Windows Server and access Gitea from there (via localhost-url AND host-url). But it still cannot be a firewall problem otherwise curl would not work, right?

The gitea logs does not show anything related to this, also not in Debug logging mode or in Debug running mode.

This is gitea 1.13.7, also tried to roll back to 1.13.6 but to no change.

I am lost. Does anyone has any ideas for me?

Well, just as I typed this, Gitea 1.14.0 was released. It works again with 1.14.0, so well. The problem remains with 1.13.7 but as it works again with 1.14.0 I will stick to the new release.

I would use the network tab of the developer tools of the browser to get more details about the errors.

  • There will be a list of black (=OK) and red (=KO) requests
  • For the red requests, you can look at error details

Maybe we can detect additional patterns this way. Maybe not.

Or just ignore the error, now that you have a solution.

I’ve looked up the network requests in developer mode in my Firefox when I ran into that error. The downloads of the css and javascript assets just failed. As well as the other pictures (but they loaded fine in a direct request).

You probably have to share more information in order to get help. Providing only the outcome of your investigations which are stuck will probably not lead to a solution.

Did you copy the urls from the developer tools into the command line in order to execute curl? I’m asking because sometimes people are ignorant about subtle changes like “http:” and “https:”… Please don’t feel offended by the question. I’m trying to help you

Thanks for your answers actually! I think I’ve put that information and all I’ve tried and the outcome in my first message in the beginning of this thread. Curl was one of the options i’ve tried, also different computers and different call strategies as well (local from server, from remote pc, firefox, edge, curl).