Unable to push after restart

After rebooting the server hosting our Gitea instance (version 1.21.1), we are unable to push to any existing repository. When trying to push we have this error:

Enumerating objects: 30, done.
Counting objects: 100% (30/30), done.
Delta compression using up to 12 threads
Compressing objects: 100% (18/18), done.
Writing objects: 100% (18/18), 12.48 KiB | 4.16 MiB/s, done.
Total 18 (delta 13), reused 0 (delta 0), pack-reused 0
remote: Gogs: Internal error
To https://git.articque.com/tlaugier/sauvegarde
 ! [remote rejected] master -> master (pre-receive hook declined)
error: failed to push some refs to 'https://git.articque.com/tlaugier/sauvegarde'

I don’t have any errors in the logs even when starting Gitea in dev mode. I’ve tried a lot of solutions I found on this forum for similar issues but so far none have worked.
As stated before the issue only occurs on existing repositories, I created a new repository after the issue was found and I can push to it without any issue. The logs are not different wether I try to do a push to this new repository or an existing one where I encounter an error.

Does anyone have an idea of what I could try to fix this issue? Since I don’t have logs indicating a precise issue I find myself at a loss here.

It sounds like you may need to re-sync your git hooks. Do you have admin access?

Yeah I found that on another thread and I already re-synced them but no luck it doesn’t change anything. I tried via the admin panel and the command line, no errors but still cannot push.