[solved] SSH cloning times out

Hi everyone,

I ran into a strange problem with my new gitea installation, namely cloning via SSH gets stuck without error message, e.g.

$ git clone --verbose git@example.com:test/test.git
Cloning into 'test'...

This process never finishes. Unfortunately, I don’t have much information to offer since there are no error messages, logs are empty and everything seems normal except it doesn’t finish. Gitea is installed on Ubuntu 14.04 using DigitalOcean’s tutorial, git version 1.9.1. I can ssh into git@example.com normally as well.

Has anyone ever had some issue like that or can point me to how to closer examine this problem?

Many thanks,

P.S. Gitea is awesome work btw :slight_smile:

It looks like I solved the issue. I just set a dfifferent DNS hostname for the server git.example.com, now it works. It must have been something with the network’s DNS configuration.


I also met the same problem with you. How did you solve it?

As I said, I just used a dedicated domain name example.com -> git.example.com

1 Like