[solved] Indentation Broken In Code View

[root@jasonralph-centos8 bin]# ./gitea --version
Gitea version 1.15.2 built with GNU Make 4.1, go1.16.7 : bindata, sqlite, sqlite_unlock_notify
[root@jasonralph-centos8 bin]# 

Hello all,
Forgive me if this has been asked before, I see a fix for indentation in the release notes.
I am running the latest version of gitea on centos8, all works well except indentation in the highlighted view, the raw file view shows the correct indentation. I use 4 spaces not tabs in my python code so not sure whats up, is there a workaround? Is this a known issue?

You wouldn’t happen to use cloudflare would you? Their “minification” filter will mess with indentation.

If you don’t use CF could you mention the reverse proxy you do use?

1 Like

Why yes, yes I do use cloud flare. I toggled the auto minify settings under SPEED menu and that fixed it. Thank you so much for your reply, now I need to dig into the cloud flare minify docs and see if I can exclude my git url. Have a great day.

1 Like