[SOLVED] Cannot restore after server migration

Hi all,

I posted about this on GitHub as an issue and as it’s been a week, I thought I would seek some advice here.


I followed these steps from the docs as I had to change my VPS provider.

During the restore process, the difficulty is with SQLite. Doing:
sqlite3 $DATABASE_PATH <gitea-db.sql
gives hundreds of errors, such as

Error: near line 1459: no such column: true
Error: near line 1460: no such column: true
Error: near line 1468: no such column: false
Error: near line 1469: no such column: false

The previous server had the same git and gitea versions.

Any suggestion would be greatly appreciated.

Hi @farhang,

In your backup is there a file name gitea.db? I recently migrated VMs, and instead of running the sql file I just put the sqlite file from my old install into the new directory.

Let me know if that works.


1 Like

I cannot thank you enough! You saved my repos! I did not have gitea.db in the zip but out of paranoia I had saved that on my own just in the case. What a case.

Thanks a million, really.

1 Like

Glad that worked :smiley: