Renovate tutorial permission error

I followed the below renovate tutorial:

And get the following error:

DEBUG: Error authenticating with Gitea. Check your token
"url": "",
FATAL: Authentication failure

I tried to put the interesting parts to pinpoint the problem, if stack trace are not enough I can provide more.

So according to the error the Token is not correct.

So what I tried so far as mentioned in the Renovate doc is to put the correct scope and permission as listed there (this part is missing in the gitea tutorial):

But even with all this permission and even more I still get the error.

I also try to access directly with postman to the user endpoint with the generated Token and here I have no problem the user data are returned so it should not be networking or typo.

I tried a lot of different pattern until give full access to the renovate bot but still have the same error.

So I’m stuck I don’t really know what more to try, any tip or advice can be really helpful. I thought it will be a strait forward tutorial but I stuck on a basic authorization error, it’s really frustrating.