Gitea not recognizing unadopted repositories

Hi, I’m trying to import an unadopted repository, however Gitea is not showing any respoitories under the “Unadopted repositories” section in the admin panel. I am working on Windows 11.

The steps I followed were:

  • Run cd C:\Gitea\data\gitea-repositories\username
  • Run git clone --bare /path/to/my/repo repo-name.git

I know the cloning process worked, and I know the cloned repo is in the right place, because I can see it in my gitea-repositories\username folder next to another repository which I can see in the web UI (a repo I created through Gitea, so already adopted). So it’s like I can see 2 repositories next to each other, but Gitea only shows one of them.

I’m not sure what else I need to do to be able to see it. I can’t find any documentation online about what to do next. It feels like I should be able to just refresh the page and see the unadopted repository on the admin panel, but that is not the case. Are there configuration settings I need to set in order to enable the adoption of unadopted repositories? I know there is a config setting literally called ALLOW_ADOPTION_OF_UNADOPTED_REPOSITORIES however that applies to non-admin users (I’m on the admin user), plus I already tried with that option enabled and it didn’t work.

I’m running version 1.22.0+rc0-64-g3735797b3 and have made zero edits to my app.ini file since installing from the Windows 64-bit AMD binary executable. Do I need to make any configuration changes to enable adoption of repositories?