Gitea Actions with Python

Hello, I use actions to test the project on python, I used to do it through github, but when I transferred to gitea and add to actions:

uses: https:/
        python-version: "3.11"

I have a mistake:

The version ‘3.11’ with architecture ‘x64’ was not found for this operating system. %0AThe list of all available versions can be found here:

Whole YML file:

name: Lint and check types

on: [push, pull_request]

    runs-on: ubuntu-20.04
    - uses: actions/checkout@v3
    - name: Set up Python 3.11
        python-version: "3.11"
    - name: Install poetry
      run: |
        pip install pipx
        pipx install poetry        

    - name: Validate the structure of the pyproject.toml
      run: |
        poetry check        

    - name: Verify that poetry.lock is consistent with pyproject.toml
      run: |
        poetry lock --check        
    - name: Install dependencies
      run: |
        poetry install        

    - name: Check code formatting by black
      run: |
        poetry run black . --check
    - name: Lint code by ruff
      run: |
        poetry run ruff .
    - name: Check types by pyright
      run: |
        poetry run pyright        

I got the same error with “setup-python@v4”.
A local build with: “act” runs without problems!

act -j build
[build/build]   ✅  Success - Main Test sphinx-build
[build/build] ⭐ Run Post Set up Python 3.11
[build/build]   🐳  docker exec cmd=[node /var/run/act/actions/actions-setup-python@v4/dist/cache-save/index.js] user= workdir=
[build/build]   ✅  Success - Post Set up Python 3.11
[build/build] 🏁  Job succeeded

Did you figure this out? I have the exact same problem.

name: Django CI

    branches: ["dev"]

    runs-on: ubuntu-latest
    container: catthehacker/ubuntu:act-latest
      - uses: actions/checkout@v3
      - name: Set up Python 3.10
        uses: actions/setup-python@v3
          python-version: "3.10.12"

As shown above, add container: catthehacker/ubuntu:act-latest and try again. This works for me.

„Just use another image“ is a pragmatic solution but I’d like to understand the issue behind it. What goes on there?


i’m setting up Gitea and having the same issue when using setup-python.
simply switching to use the catthehacker image does work. but i’m unsatisfied not knowing why. i’ve tried a large variety of variants attempting to replicate creating it but have failed every time.

could someone please help explain how this catthehacker image is provisioned to make it work?