Client.Timeout exceeded while awaiting headers

When attempting to post to drone, i get the following error from the webhook.

What could be wrong?

Delivery: Post "": context deadline exceeded (Client.Timeout exceeded while awaiting headers)

You can ping drone server from Gitea to test if connection is normal.

Hi Lunny,
Unfortunately some PR requests for the webhooks are working, others are not.
It seems to be that the webhook works sometimes based on PR content, and othertimes it doesnt.

It turns out i was missing .drone.yml file, i had a drone.yml file from last version.
Would be nice to have a clearer error though, left us going in circles :slight_smile:

1 Like

i had the same problem,i event dont konw drone.yml file,how to find my drone.yml file,thanks

FYI: below is the python code where i solved this problem:

# when my python server received the webhook POST request,
# response the gitea server withe header Content-Length set to 0 solved this problem
def do_POST(self):
    self.send_header("Content-Length", "0")