Can't connect with SSH

Hi, I’ve just installed Gitea pretty much with default settings. Everythings seems to work fine, expect that I can’t connect/clone/push with SSH.

  • The SSH url is correct: ssh://
  • I’ve added the SSH key through the WebUI, didn’t touch git user’s .authorized_keys manually.
  • I’m using nginx as a reverse proxy (with LE TLS) in front of Gitea.
  • With another user I can connect (with the same key) to the server with ssh user@ip -p 420
  • I see the server banner and error message Permission denied (publickey).

Any ideas what could be wrong here?

Well… I automatically lock down SSH on all my servers, so that only users in a specific group are allowed to connect via SSH. I forgot to add the git user to that group.

Problem solved and it had nothing to do with Gitea itself.



Thank you so much kind human bean! :pleading_face::pleading_face::pleading_face:

I was going made about this, I could not figure it out… I had my sshd settings set to the same, to only allow certain users… Once I added “gitea” and an AllowedUser it all just worked!