Can't clone or pull repository

When I try to clone or pull a repository (no matter ssh to HTTPS) I get the error:

remote: aborting due to possible repository corruption on the remote side.
Gitea: Internal error
fatal: unexpected end of file
fatal: fetch-pack: invalid index-pack output
Gitea: Internal error

I tried to clone on two machines (Linux & WSL). Same error. On the first machine, my repository has been cloned and I can push commits. In the Gitea Web interface I see changes. I also tried:

git config --global pack.windowMemory "100m"
git config --global pack.SizeLimit "100m"
git config --global pack.threads "1"

The Gitea instance is deployed in the cluster. I also tried to clone the needed repository from each node.

P.S: I had a same error a few days ago. Then I just created a new repository and commit my files. But today I had to pull changes on the second machine (WSL)

I figured it out. It’s a memory issue. I increased the memory limit in the containers orchestrator I am using and it worked. But it is strange to there isn’t any information about that in logs. Just 500 Interval error.

Because you are running the instance in production mode. For security consider, it will not display the detail error information. If you change the RUN_MODE to dev, it will display the details.

1 Like