Backup/Restore to new version -> Internal Server Error


I just tried to move gitea from a docker env to a kubernetes env using the newest version. Gitea is runing, I can login with my know users, I can pull a repository, I can create a repository and I can search through repositories.

But trying to push changes to gitea to an existing repository gives me the following error:

Total 38 (delta 17), reused 0 (delta 0)
remote: Gitea: Internal Server Error
remote: Unable to contact gitea: Post net/http: invalid header field value "Bearer eyJhbGciOiJIUzI1NiIsInR5cCI6IkpXVCJ9.eyJuYmYiOjE1MjI3NTE0NTR9.4W2_i5BAvlHoSWQxzLLHRrgnYWY4h_M3AYa45q3v204\n" for key Authorization
To http://gitea.velo/sys/k8s.git
 ! [remote rejected] master -> master (pre-receive hook declined)
error: failed to push some refs to 'http://gitea.velo/sys/k8s.git'

gitea itself has nothing in it’s logs regarding this error

Creating a new repository and trying the same again (pull, make some local changes, and push) will throw the exact same error.

I also executed:
app/gitea$ ./gitea admin regenerate hooks -c /data/gitea/conf/app.ini
to regenerate the hooks → no change, still the same error

What am I missing here?