# Gitea crashes on startup after upgrade from 18.3 to 19.3

**URL:** <https://forum.gitea.com/t/gitea-crashes-on-startup-after-upgrade-from-18-3-to-19-3/7424>\
**Category:** Install/Maintain/Configure\
**Created:** [June 14, 2023, 1:43am UTC](https://forum.gitea.com/t/gitea-crashes-on-startup-after-upgrade-from-18-3-to-19-3/7424 "2023-06-14T01:43:11Z")\
**Posts on this page:** 8\
**Page:** 1

<div class="post-metadata">

**Author:** ![Oloryn](https://sea2.discourse-cdn.com/flex020/user_avatar/forum.gitea.com/oloryn/32/4935_2.png) [@Oloryn](https://forum.gitea.com/u/Oloryn)\
**Post date:** [June 14, 2023, 1:43am UTC](https://forum.gitea.com/t/gitea-crashes-on-startup-after-upgrade-from-18-3-to-19-3/7424/1 "2023-06-14T01:43:11Z")

</div>

I upgraded my personal Gitea (installed on Ubuntu 22.04, using PostgreSQL 14) from 18.3 to 19.3, and Gitea now crashes on startup, exiting with code 1.

Figuring that it might have messed up the database, I pulled that morning’s database from backup and reverted back to 18.3. I’m now getting the same problem.

A check on /var/lib/gitea/log/gitea.log shows this at the point where gitea crashes:

# ========================================= 2023/06/13 21:25:46 …xer/stats/indexer.go:39:populateRepoIndexer() [I] Populating the repo stats indexer with existing rep ositories 2023/06/13 21:25:46 …er/issues/indexer.go:191:func2() [F] [6489171a-3] Unable to initialize Bleve Issue Indexer at path: / var/lib/gitea/data/indexers/issues.bleve Error: error parsing mapping JSON: error building analyzer: no token filter with na me or type ‘camelCase’ registered mapping contents: {“types”:{“\_all”:{“enabled”:false,“dynamic”:false},“issueIndexerDocType”:{“enabled”:true,“dynamic”:true,“properties” :{“Comments”:{“enabled”:true,“dynamic”:true,“fields”:[{“type”:“text”,“index”:true,“include\_term\_vectors”:true,“docvalues”:tr ue}]},“Content”:{“enabled”:true,“dynamic”:true,“fields”:[{“type”:“text”,“index”:true,“include\_term\_vectors”:true,“docvalues” :true}]},“RepoID”:{“enabled”:true,“dynamic”:true,“fields”:[{“type”:“number”,“store”:true,“index”:true,“docvalues”:true}]},“T itle”:{“enabled”:true,“dynamic”:true,“fields”:[{“type”:“text”,“index”:true,“include\_term\_vectors”:true,“docvalues”:true}]}}} },“default\_mapping”:{“enabled”:true,“dynamic”:true},“type\_field”:“\_type”,“default\_type”:“\_default”,“default\_analyzer”:“issue Indexer”,“default\_datetime\_parser”:“dateTimeOptional”,“default\_field”:“\_all”,“store\_dynamic”:true,“index\_dynamic”:true,“docv alues\_dynamic”:true,“analysis”:{“token\_filters”:{“unicodeNormalize”:{“form”:“nfc”,“type”:“normalize\_unicode”}},“analyzers”:{ “issueIndexer”:{“char\_filters”:,“token\_filters”:[“unicodeNormalize”,“camelCase”,“to\_lower”],“tokenizer”:“unicode”,“type”:" custom"}}}}

Any idea what I can do to fix this?

I’m holding off on upgrading the work Gitea site until I’m sure that it wasn’t the upgrade to 19.3 that caused this.

---

<div class="post-metadata">

**Author:** ![eeyrjmr](https://sea2.discourse-cdn.com/flex020/user_avatar/forum.gitea.com/eeyrjmr/32/1095_2.png) [@eeyrjmr](https://forum.gitea.com/u/eeyrjmr)\
**Post date:** [June 14, 2023, 1:50am UTC](https://forum.gitea.com/t/gitea-crashes-on-startup-after-upgrade-from-18-3-to-19-3/7424/2 "2023-06-14T01:50:06Z")

</div>

A very similar issue was raised on discord recently and the advice was to backup the bleve cache and restart.  
Everything worked

 ![Screenshot_20230614-024830](https://us1.discourse-cdn.com/flex020/uploads/gitea/original/2X/d/d2a42f43a5776d9276cdeef6309fcef801e3c673.png)

---

<div class="post-metadata">

**Author:** ![Oloryn](https://sea2.discourse-cdn.com/flex020/user_avatar/forum.gitea.com/oloryn/32/4935_2.png) [@Oloryn](https://forum.gitea.com/u/Oloryn)\
**Post date:** [June 14, 2023, 3:22am UTC](https://forum.gitea.com/t/gitea-crashes-on-startup-after-upgrade-from-18-3-to-19-3/7424/3 "2023-06-14T03:22:33Z")

</div>

Actually, that message is showing that it _didn’t_ work.

In my case, moving the bleve cache elsewhere and restarting Gitea brought it back, but only if I move back to 18.3. Upgrading to 19.3 results in the same crash on the bleve cache, and removing the cache and restarting Gitea does _not_ work on 19.3. I have to revert to 18.3 to get Gitea to work.

---

<div class="post-metadata">

**Author:** ![eeyrjmr](https://sea2.discourse-cdn.com/flex020/user_avatar/forum.gitea.com/eeyrjmr/32/1095_2.png) [@eeyrjmr](https://forum.gitea.com/u/eeyrjmr)\
**Post date:** [June 14, 2023, 6:13am UTC](https://forum.gitea.com/t/gitea-crashes-on-startup-after-upgrade-from-18-3-to-19-3/7424/4 "2023-06-14T06:13:02Z")

</div>

Look closer at the new error, it might be pointing to a different file this time

This is the 2nd half of the conv where the OP did say it didn’t work (one file moved)

 ![Screenshot_20230614-071132](https://us1.discourse-cdn.com/flex020/uploads/gitea/original/2X/5/5fb3027b9e68ee2f9753cfeb1cd6f968a79d2f57.png)

---

<div class="post-metadata">

**Author:** ![Oloryn](https://sea2.discourse-cdn.com/flex020/user_avatar/forum.gitea.com/oloryn/32/4935_2.png) [@Oloryn](https://forum.gitea.com/u/Oloryn)\
**Post date:** [June 23, 2023, 9:17pm UTC](https://forum.gitea.com/t/gitea-crashes-on-startup-after-upgrade-from-18-3-to-19-3/7424/5 "2023-06-23T21:17:01Z")

</div>

That worked for getting back to working on 1.18.3. Trying again to get back to working on 1.19.3 now gives me the error:

# ================================ 2023/06/23 17:07:08 …rvices/cron/tasks.go:199:RegisterTaskFatal() [F] [6496097b-17] Unable to register cron task gc\_lfs Error: translation is missing for task “gc\_lfs”, please add translation for “admin.dashboard.gc\_lfs”

---

<div class="post-metadata">

**Author:** ![jake](https://avatars.discourse-cdn.com/v4/letter/j/f475e1/32.png) [@jake](https://forum.gitea.com/u/jake)\
**Post date:** [June 24, 2023, 2:26am UTC](https://forum.gitea.com/t/gitea-crashes-on-startup-after-upgrade-from-18-3-to-19-3/7424/6 "2023-06-24T02:26:41Z")

</div>

See this post [Problems moving gitea instance to new server - #8 by wxiaoguang](https://forum.gitea.com/t/problems-moving-gitea-instance-to-new-server/6687/8) on how to resolve that error.

---

<div class="post-metadata">

**Author:** ![Oloryn](https://sea2.discourse-cdn.com/flex020/user_avatar/forum.gitea.com/oloryn/32/4935_2.png) [@Oloryn](https://forum.gitea.com/u/Oloryn)\
**Post date:** [October 24, 2023, 12:02pm UTC](https://forum.gitea.com/t/gitea-crashes-on-startup-after-upgrade-from-18-3-to-19-3/7424/7 "2023-10-24T12:02:05Z")

</div>

I got this figured out. At some point I investigated customization, and had left the options/locale/locale\_en-US.ini file in the custom directory. I’m assuming that admin.dashboard.gc\_lfs is removed in versions later than 18.3, so the locale\_en-US.ini (from 18.3 or earlier) no longer matched the program. I removed the locale\_en-US.ini file and Gitea works again.

---

<div class="post-metadata">

**Author:** ![lunny](https://sea2.discourse-cdn.com/flex020/user_avatar/forum.gitea.com/lunny/32/4701_2.png) [@lunny](https://forum.gitea.com/u/lunny)\
**Post date:** [October 24, 2023, 1:37pm UTC](https://forum.gitea.com/t/gitea-crashes-on-startup-after-upgrade-from-18-3-to-19-3/7424/8 "2023-10-24T13:37:29Z")

</div>

You can remove all removed translations from your customized translation file. I think then it will work.
