# Gitea container container fails to start

**URL:** <https://forum.gitea.com/t/gitea-container-container-fails-to-start/10935>\
**Category:** Install/Maintain/Configure\
**Created:** [March 14, 2025, 12:39am UTC](https://forum.gitea.com/t/gitea-container-container-fails-to-start/10935 "2025-03-14T00:39:41Z")\
**Posts on this page:** 2\
**Page:** 1

<div class="post-metadata">

**Author:** ![Sparky](https://sea2.discourse-cdn.com/flex020/user_avatar/forum.gitea.com/sparky/32/6740_2.png) [@Sparky](https://forum.gitea.com/u/Sparky)\
**Post date:** [March 14, 2025, 12:39am UTC](https://forum.gitea.com/t/gitea-container-container-fails-to-start/10935/1 "2025-03-14T00:39:41Z")

</div>

I was trying to upgrade from `gitea/gitea:1.22.3` image to `gitea/gitea:1.3`

After this I wanted to start again the 1.22.3 image but I’m getting the following messages in loop and while gitea container would run the service isn’t available:

```auto
% docker logs -f gitea
Mar 14 00:38:46 syslogd started: BusyBox v1.26.2
/etc/ssh/sshd_config line 32: Deprecated option UsePrivilegeSeparation
Mar 14 00:38:46 sshd[20]: Server listening on :: port 22.
Mar 14 00:38:46 sshd[20]: Server listening on 0.0.0.0 port 22.
2025/03/14 00:38:47 [T] AppPath: /app/gitea/gitea
2025/03/14 00:38:47 [T] AppWorkPath: /app/gitea
2025/03/14 00:38:47 [T] Custom path: /data/gitea
2025/03/14 00:38:47 [T] Log path: /data/gitea/log
2025/03/14 00:38:48 [T] AppPath: /app/gitea/gitea
2025/03/14 00:38:48 [T] AppWorkPath: /app/gitea
2025/03/14 00:38:48 [T] Custom path: /data/gitea
2025/03/14 00:38:48 [T] Log path: /data/gitea/log
2025/03/14 00:38:49 [T] AppPath: /app/gitea/gitea
2025/03/14 00:38:49 [T] AppWorkPath: /app/gitea
2025/03/14 00:38:49 [T] Custom path: /data/gitea
2025/03/14 00:38:49 [T] Log path: /data/gitea/log
2025/03/14 00:38:49 [I] Gitea v1.3.2+6-g86d61bb built with: bindata, sqlite

```

```auto
Server listening on :: port 22.
Server listening on 0.0.0.0 port 22.
2025/03/14 00:34:56 cmd/web.go:242:runWeb() [I] Starting Gitea on PID: 15
2025/03/14 00:34:56 cmd/web.go:111:showWebStartupMessage() [I] Gitea version: 1.22.3 built with GNU Make 4.4.1, go1.22.8 : bindata, timetzdata, sqlite, sqlite_unlock_notify
2025/03/14 00:34:56 cmd/web.go:112:showWebStartupMessage() [I] * RunMode: prod
2025/03/14 00:34:56 cmd/web.go:113:showWebStartupMessage() [I] * AppPath: /usr/local/bin/gitea
2025/03/14 00:34:56 cmd/web.go:114:showWebStartupMessage() [I] * WorkPath: /data/gitea
2025/03/14 00:34:56 cmd/web.go:115:showWebStartupMessage() [I] * CustomPath: /data/gitea
2025/03/14 00:34:56 cmd/web.go:116:showWebStartupMessage() [I] * ConfigFile: /data/gitea/conf/app.ini
2025/03/14 00:34:56 cmd/web.go:117:showWebStartupMessage() [I] Prepare to run web server
2025/03/14 00:34:56 routers/init.go:116:InitWebInstalled() [I] Git version: 2.45.2 (home: /data/gitea/home)

```

Do you have an idea what should I try next?

---

<div class="post-metadata">

**Author:** ![Sparky](https://sea2.discourse-cdn.com/flex020/user_avatar/forum.gitea.com/sparky/32/6740_2.png) [@Sparky](https://forum.gitea.com/u/Sparky)\
**Post date:** [March 14, 2025, 12:51am UTC](https://forum.gitea.com/t/gitea-container-container-fails-to-start/10935/2 "2025-03-14T00:51:11Z")

</div>

Even if I change the ssh port or disable it it will still try to bind to port 22, it seems like my `/data/gitea/gitea/conf/app.ini` is being ignored.
