# 使用 docker 模式运行 runner，在 workflow 里运行 docker 挂载失败

**URL:** <https://forum.gitea.com/t/docker-runner-workflow-docker/9878>\
**Category:** 中文求助(Chinese Only)\
**Created:** [October 18, 2024, 3:18am UTC](https://forum.gitea.com/t/docker-runner-workflow-docker/9878 "2024-10-18T03:18:54Z")\
**Posts on this page:** 2\
**Page:** 1

<div class="post-metadata">

**Author:** ![p1g3](https://sea2.discourse-cdn.com/flex020/user_avatar/forum.gitea.com/p1g3/32/6328_2.png) [@p1g3](https://forum.gitea.com/u/p1g3)\
**Post date:** [October 18, 2024, 3:18am UTC](https://forum.gitea.com/t/docker-runner-workflow-docker/9878/1 "2024-10-18T03:18:54Z")

</div>

我使用 docker 启动了一个 runner，并在我的 workflow 里的某个 step 调用了 maven 的 docker，希望使用 docker 自动编译代码并产生输出。

但是 docker run -v .:/app 挂载失败了，ls /app 发现是空的，但是目录却可以挂进去。

runner 是通过 docker.sock 把我宿主机的 docker 挂进去的，不知道会不会受到影响，以及如何解决呢？ 😭

---

<div class="post-metadata">

**Author:** ![visonforcoding](https://sea2.discourse-cdn.com/flex020/user_avatar/forum.gitea.com/visonforcoding/32/7093_2.png) [@visonforcoding](https://forum.gitea.com/u/visonforcoding)\
**Post date:** [September 12, 2025, 8:36am UTC](https://forum.gitea.com/t/docker-runner-workflow-docker/9878/2 "2025-09-12T08:36:57Z")

</div>

我也遇到了好像，你猜怎么回事。

```auto
jobs:
  build:
    # 运行环境（Gitea Actions 支持的 runner 环境）
    runs-on: ubuntu-latest
    container:
      image: visonforcoding/gitea-runner-jdk8:0.1
      options: --user root
      volumes:
        - /home/yours/config-data/gitea/config:/config:rw

```

这里挂宿主机的绝对路径就可以了。一开始一直以为是runner容器里的目录。

发现挂上去之后都是空的。

并且当挂了一个找不到的相对目录时。会报错

> failed to create container: ‘Error response from daemon: create ./config: “./config” includes invalid characters for a local volume name, only “[a-zA-Z0-9][a-zA-Z0-9\_.-]” are allowed. If you intended to pass a host directory, use absolute path’

看上去也是支持挂宿主机的目录的。🤣
