# Cant' connect with ssh user

**URL:** <https://forum.gitea.com/t/cant-connect-with-ssh-user/242>\
**Category:** Install/Maintain/Configure\
**Created:** [April 3, 2018, 7:35pm UTC](https://forum.gitea.com/t/cant-connect-with-ssh-user/242 "2018-04-03T19:35:26Z")\
**Posts on this page:** 2\
**Page:** 1

<div class="post-metadata">

**Author:** ![nicod](https://sea2.discourse-cdn.com/flex020/user_avatar/forum.gitea.com/nicod/32/143_2.png) [@nicod](https://forum.gitea.com/u/nicod)\
**Post date:** [April 3, 2018, 7:35pm UTC](https://forum.gitea.com/t/cant-connect-with-ssh-user/242/1 "2018-04-03T19:35:26Z")

</div>

Hello,

I installed Gitea 1.4.0 binary on my server, everything’s fine except i can’t connect anymore on my server with the ssh user, I had to create another ssh user.  
I tried to comment RUN\_USER = gitea in app.ini, no success.  
_(btw, commenting in app.ini is with a # as first character, right ?)_

```
# ssh gitea@ ******.net
PTY allocation request failed on channel 0
Hi there, You've successfully authenticated, but Gitea does not provide shell access.
If this is unexpected, please log in with password and setup Gitea under another user.
Connection to ***.net closed.

```

I tried with a minimalist app.ini (only INTERNAL\_TOKEN in app.ini):

```
# ssh gitea@ ******.net
PTY allocation request failed on channel 0
Gitea: System init failed
setup: Failed to connect to database: Unknown database type:
Connection to ***.net closed. 

```

What’s wrong ?

Thx,  
nicod\_

```
APP_NAME = Gitea: Git with a cup of tea
RUN_USER = gitea
RUN_MODE = prod

[security]
INTERNAL_TOKEN = ***
INSTALL_LOCK = true
SECRET_KEY = ***

[server]
PROTOCOL = http
DOMAIN = ***.fr
ROOT_URL = http://***.fr/
HTTP_ADDR = 127.2.94.120
HTTP_PORT = 8100
SSH_DOMAIN = ***.net
DISABLE_SSH = false
SSH_PORT = 22
LFS_START_SERVER = true
LFS_CONTENT_PATH = /home/gitea/data/lfs
LFS_JWT_SECRET = ***
OFFLINE_MODE = false

[database]
DB_TYPE = mysql
HOST = ***:3306
NAME = gitea_db
USER = gitea
PASSWD = ***
SSL_MODE = disable
PATH = data/gitea.db

[repository]
ROOT = /home/gitea/gitea-repositories

[mailer]
ENABLED = false

[service]
REGISTER_EMAIL_CONFIRM = true
ENABLE_NOTIFY_MAIL = true
DISABLE_REGISTRATION = true
ENABLE_CAPTCHA = false
REQUIRE_SIGNIN_VIEW = true
DEFAULT_KEEP_EMAIL_PRIVATE = false
DEFAULT_ALLOW_CREATE_ORGANIZATION = false
DEFAULT_ENABLE_TIMETRACKING = true
NO_REPLY_ADDRESS = noreply.***.fr

[picture]
DISABLE_GRAVATAR = false
ENABLE_FEDERATED_AVATAR = true

[openid]
ENABLE_OPENID_SIGNIN = false
ENABLE_OPENID_SIGNUP = false

[session]
PROVIDER = file

[log]
MODE = file
LEVEL = Info
ROOT_PATH = /home/gitea/log
```

---

<div class="post-metadata">

**Author:** ![nicod](https://sea2.discourse-cdn.com/flex020/user_avatar/forum.gitea.com/nicod/32/143_2.png) [@nicod](https://forum.gitea.com/u/nicod)\
**Post date:** [April 3, 2018, 8:50pm UTC](https://forum.gitea.com/t/cant-connect-with-ssh-user/242/2 "2018-04-03T20:50:30Z")

</div>

I see in the doc:

> Gitea should be run with a dedicated non-root system account on UNIX-type systems.  
> Note: Gitea manages the ~/.ssh/authorized\_keys file. Running gitea as a regular user could break that user’s ability to log in.

That’s the problem…
